Performance degradation affecting Tanzania Halotel services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Oct 04, 2024 - 21:48 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Oct 04, 2024 - 21:07 UTC
Identified
We have identified instability in Tanzania Halotel services. We have escalated this to the MNO for resolution.
Posted Oct 04, 2024 - 16:31 UTC
This incident affected: Tanzania MNO services (Halotel :: Web Deposit).