This is a quick update to inform you that we are still experiencing instability in Kenya M-Pesa services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 27, 2026 - 14:58 UTC
Update
We are still experiencing instability in Kenya M-Pesa services, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 27, 2026 - 02:51 UTC
Update
This is a quick update to inform you that we are still experiencing instability in Kenya M-Pesa services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 26, 2026 - 16:14 UTC
Identified
We have identified instability in Kenya M-Pesa services. We have escalated this to the MMO for resolution.
Posted Jan 26, 2026 - 08:39 UTC
This incident affected: Kenya MMO services (M-Pesa :: Web Deposit, M-Pesa :: USSD Deposit, M-Pesa :: Payout).