Performance degradation affecting Tanzania Halotel services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Nov 26, 2024 - 15:05 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 26, 2024 - 13:40 UTC
Identified
We have identified instability in Tanzania Halotel services. We have escalated this to the MMO for resolution.
Posted Nov 26, 2024 - 12:55 UTC
This incident affected: Tanzania MMO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).