Performance degradation affecting Kenya M-Pesa services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Nov 28, 2024 - 00:55 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 28, 2024 - 00:07 UTC
Identified
We have identified instability in Kenya M-Pesa services. We have escalated this to the MMO for resolution.
Posted Nov 27, 2024 - 23:54 UTC
This incident affected: Kenya MMO services (M-Pesa :: Web Deposit, M-Pesa :: USSD Deposit, M-Pesa :: Payout).