Performance degradation affecting Intouch Cameroon Orange services

Incident Report for pawaPay

Resolved

We are experiencing degraded performance in the Intouch Cameroon Orange services.
Posted Aug 13, 2025 - 00:45 UTC

Identified

This is a quick update to inform you that we are still experiencing degraded performance in our Intouch Cameroon Orange payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Aug 12, 2025 - 20:27 UTC

Investigating

We are experiencing degraded performance in the Intouch Cameroon Orange services. We are investigating the issue.
Posted Aug 10, 2025 - 22:53 UTC
This incident affected: Cameroon MMO services (Orange :: Payout).