Performance degradation affecting Benin MTN services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 02:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 01:40 UTC

Investigating

We are experiencing an outage of the Benin MTN services. We are investigating the issue.
Posted Mar 24, 2026 - 22:42 UTC
This incident affected: Benin MMO services (MTN :: Web Deposit, MTN :: Payout, MTN :: Betting :: Web Deposit, MTN :: Betting :: Payout).