We are seeing improvements in success rates and will continue monitoring the incident.
Posted Sep 09, 2025 - 09:22 UTC
Update
Unfortunately we are still experiencing degraded performance in our Airtel Malawi deposit and payout gateways. Airtel is still working on restoring their services but have not given us an ETA for a resolution. We'll provide an update as soon as possible. Thank you for your patience.
Posted Sep 09, 2025 - 08:51 UTC
Identified
We have identified instability in Malawi Airtel services. We have escalated this to the MMO for resolution.
Posted Sep 09, 2025 - 02:30 UTC
Monitoring
A fix has been deployed by Malawi Airtel. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Sep 09, 2025 - 01:50 UTC
Investigating
We are experiencing degraded performance in the Malawi Airtel services. We are investigating the issue.
Posted Sep 09, 2025 - 00:04 UTC
This incident affected: Malawi MMO services (Airtel :: Web Deposit, Airtel :: Payout).