Performance degradation affecting Uganda MTN services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 03:14 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 03, 2025 - 23:46 UTC

Update

This is a quick update to inform you that we are still experiencing degraded performance in our MTN Uganda payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Apr 03, 2025 - 22:47 UTC

Identified

We have identified instability in Uganda MTN services. We have escalated this to the MMO for resolution.
Posted Apr 03, 2025 - 22:08 UTC
This incident affected: Uganda MMO services (MTN :: Web Deposit, MTN :: USSD Deposit, MTN :: Payout).