Performance degradation affecting Ghana AirtelTigo services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Nov 29, 2024 - 15:27 UTC
Monitoring
A fix has been deployed by Ghana AirtelTigo. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 29, 2024 - 13:41 UTC
Identified
We have identified instability in Ghana AirtelTigo services. We have escalated this to the MMO for resolution.
Posted Nov 29, 2024 - 11:17 UTC
This incident affected: Ghana MMO services (AirtelTigo :: Web Deposit, AirtelTigo :: Payout).