We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 12, 2025 - 15:16 UTC
Update
This is a quick update to inform you that we are still experiencing an outage of the Cameroon Orange + Intouch services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Nov 12, 2025 - 12:25 UTC
Update
This is a quick update to inform you that we are still experiencing an outage of the Cameroon Orange + Intouch services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Nov 12, 2025 - 05:11 UTC
Identified
We are experiencing an outage of the Cameroon Orange + Intouch services. We are investigating the issue.
Posted Nov 11, 2025 - 16:11 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 11, 2025 - 13:16 UTC
Investigating
We are experiencing an outage of the Cameroon Orange + Intouch services. We are investigating the issue.
Posted Nov 11, 2025 - 12:59 UTC
This incident affected: Cameroon MMO services (Orange :: Web Deposit, Orange :: Payout).