Performance degradation affecting Tanzania MMO services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 27, 2025 - 07:20 UTC

Identified

We have identified instability in Tanzania Vodacom services. We have escalated this to the MMO for resolution.
Posted Mar 27, 2025 - 04:28 UTC
This incident affected: Tanzania MMO services (Vodacom :: Web Deposit, Vodacom :: USSD Deposit, Vodacom :: Payout).