Performance degradation affecting Benin Celtiis/MTN/Moov services

Incident Report for PawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Jan 08, 2026 - 14:40 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jan 08, 2026 - 12:16 UTC

Investigating

We are experiencing an outage of the Benin Celtiis/MTN/Moov services. We are investigating the issue.
Posted Jan 08, 2026 - 11:14 UTC

Identified

We have identified instability in Benin Celtiis/MTN/Moov services. We have escalated this to the MMO for resolution.
Posted Jan 08, 2026 - 08:12 UTC
This incident affected: Benin MMO services (Celtiis :: Betting :: Web Deposit, Celtiis :: Betting :: Payout, Moov :: Betting :: Web Deposit, Moov :: Betting :: Payout, MTN :: Betting :: Web Deposit, MTN :: Betting :: Payout).