Performance degradation affecting Cameroon Orange ( + Intouch ) services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Apr 21, 2025 - 15:32 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 21, 2025 - 14:41 UTC

Identified

We have identified instability in Cameroon Orange ( + Intouch ) services. We have escalated this to the MMO for resolution.
Posted Apr 21, 2025 - 14:23 UTC
This incident affected: Cameroon MMO services (Orange :: Web Deposit, Orange :: Payout).