Performance degradation affecting Ghana AirtelTigo services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 07:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2025 - 06:37 UTC

Investigating

We are experiencing an outage in the Ghana AirtelTigo services. We are investigating the issue.
Posted Jun 15, 2025 - 05:58 UTC
This incident affected: Ghana MMO services (AirtelTigo :: Web Deposit, AirtelTigo :: Payout).