Performance degradation affecting Zambia Zamtel services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Mar 21, 2026 - 02:23 UTC

Investigating

We are experiencing an outage of the Zambia Zamtel services. We are investigating the issue.
Posted Mar 20, 2026 - 23:40 UTC
This incident affected: Zambia MMO services (NFS :: Zamtel :: Payout, Zamtel :: Web Deposit, Zamtel :: Payout, Zamtel :: USSD Deposit).