Performance degradation affecting Tanzania Halotel services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 09:53 UTC

Monitoring

A fix has been deployed by our engineering team. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jul 10, 2026 - 08:32 UTC

Update

We are still experiencing instabilities in our Halotel Tanzania deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Jul 10, 2026 - 07:33 UTC

Update

This is an update that we are still facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jul 10, 2026 - 01:05 UTC

Identified

Halotel Tanzania is facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jul 09, 2026 - 14:42 UTC

Investigating

We are experiencing degraded performance in the Tanzania Halotel services. We are investigating the issue.
Posted Jul 09, 2026 - 14:32 UTC
This incident affected: Tanzania MMO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).