Performance degradation affecting DRC Orange services

Incident Report for PawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Apr 02, 2026 - 20:20 UTC

Monitoring

A fix has been deployed by DRC Orange. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 02, 2026 - 19:15 UTC

Identified

Orange DRC is still facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Apr 02, 2026 - 16:49 UTC

Monitoring

A fix has been deployed by DRC Orange. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 02, 2026 - 16:08 UTC

Investigating

We are experiencing an outage of the DRC Orange services. We are investigating the issue.
Posted Apr 02, 2026 - 14:25 UTC
This incident affected: DRC MMO services (Orange :: Web Deposit, Orange :: Payout).