Performance degradation affecting Rwanda MTN services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 23:51 UTC
Investigating
We are experiencing an outage of the Rwanda MTN services. We are investigating the issue.
Posted Oct 07, 2024 - 22:36 UTC
This incident affected: Rwanda MNO services (MTN :: Web Deposit, MTN :: Payout).