Performance degradation affecting Rwanda MTN services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 20:39 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Oct 10, 2024 - 19:39 UTC
Identified
We have identified instability in Rwanda MTN services. We have escalated this to the MNO for resolution.
Posted Oct 10, 2024 - 16:59 UTC
This incident affected: Rwanda MNO services (MTN :: Web Deposit, MTN :: Payout).