Performance degradation affecting Kenya M-Pesa services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Apr 22, 2025 - 20:51 UTC

Investigating

We are experiencing degraded performance in the Kenya M-Pesa services. We are investigating the issue.
Posted Apr 22, 2025 - 19:18 UTC
This incident affected: Kenya MMO services (M-Pesa :: Web Deposit).