Performance degradation affecting Tanzania Yas services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 02:12 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Dec 10, 2025 - 21:57 UTC

Identified

Unfortunately we are still experiencing an outage in our Tanzania Yas deposit gateway. Yas is still working on restoring their services . We'll provide an update as soon as possible. Thank you for your patience.
Posted Dec 10, 2025 - 18:40 UTC

Monitoring

A fix has been deployed by Tanzania Yas. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Dec 10, 2025 - 18:36 UTC

Identified

Unfortunately we are still experiencing an outage in our Tanzania Yas deposit and payout gateways. Yas is still working on restoring their services but have not given us an ETA for a resolution. We'll provide an update as soon as possible. Thank you for your patience.
Posted Dec 10, 2025 - 16:28 UTC

Investigating

We are experiencing an outage of the Tanzania Yas services. We are investigating the issue.
Posted Dec 10, 2025 - 13:19 UTC
This incident affected: Tanzania MMO services (Yas :: Web Deposit, Yas :: USSD Deposit, Yas :: Payout).