Performance degradation affecting Malawi Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 12:54 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 24, 2025 - 09:06 UTC

Identified

We have identified instability in Malawi Airtel services. We have escalated this to the MMO for resolution.
Posted Mar 23, 2025 - 04:33 UTC
This incident affected: Malawi MMO services (Airtel :: Web Deposit, Airtel :: Payout).