Performance degradation affecting Zambia Zamtel services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 20:32 UTC

Investigating

We are experiencing an outage of the Zambia Zamtel services. We are investigating the issue.
Posted Feb 10, 2026 - 20:21 UTC
This incident affected: Zambia MMO services (NFS :: Zamtel :: Payout).