Performance degradation affecting Tanzania Halotel MMO services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Apr 12, 2025 - 20:36 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 12, 2025 - 20:07 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 12, 2025 - 19:27 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 12, 2025 - 16:03 UTC

Identified

We have identified instability in Tanzania Halotel services. We have escalated this to the MMO for resolution.
Posted Apr 12, 2025 - 14:00 UTC
This incident affected: Tanzania MMO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).