Performance degradation affecting Tanzania Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 00:39 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 19, 2025 - 00:02 UTC

Update

This is a quick update to inform you that we are still experiencing an outage in our Airtel Tanzania deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Mar 18, 2025 - 22:55 UTC

Identified

We have identified instability in Tanzania Airtel services. We have escalated this to the MMO for resolution.
Posted Mar 18, 2025 - 22:32 UTC
This incident affected: Tanzania MMO services (Airtel :: Web Deposit).