We are informing you that our systems are up and running again and all services are fully operational. In case you should encounter any further problems, please do not hesitate to contact our support team. We apologize for the inconvenience caused.
Posted Mar 11, 2026 - 02:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 22:05 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2026 - 20:37 UTC
Identified
Dear Customer! We are currently experiencing an outage in our internal systems which affects processing transactions in all gateways. Our engineering team is working on resolving the issue. Thank you for your understanding.
Posted Mar 10, 2026 - 20:36 UTC
This incident affected: Cameroon MMO services (MTN :: Web Deposit, MTN :: Payout, Orange :: Web Deposit, Orange :: Payout), PawaPay platform (PawaPay Merchant API, PawaPay Dashboard, Payment reconciliation), Burkina Faso MMO services (Moov :: Web Deposit, Moov :: Payout, Orange :: Web Deposit), Ghana MMO services (Telecel :: Payout), and Zambia MMO services (Zamtel :: Web Deposit, Zamtel :: Payout, Zamtel :: USSD Deposit).