Performance degradation affecting Senegal MMO services

Incident Report for pawaPay

Update

Please be advised that our payment services in Senegal are temporarily interrupted as we await the issuance of a payment systems license from BCEAO. This is mandated by the new regulation in Senegal governing fintechs. We are in positive dialogue with BCEAO and other relevant stakeholders around this matter and expect a positive resolution shortly.
We apologise for any inconvenience this may cause and will provide updates as the situation progresses
Posted Sep 15, 2025 - 03:21 UTC

Update

Please be advised that our payment services in Senegal are temporarily interrupted as we await the issuance of a payment systems license from BCEAO. This is mandated by the new regulation in Senegal governing fintechs. We are in positive dialogue with BCEAO and other relevant stakeholders around this matter and expect a positive resolution shortly.
We apologise for any inconvenience this may cause and will provide updates as the situation progresses
Posted Sep 04, 2025 - 08:51 UTC

Update

Please be advised that our payment services in Senegal are temporarily interrupted as we await the issuance of a payment systems license from BCEAO. This is mandated by the new regulation in Senegal governing fintechs. We are in positive dialogue with BCEAO and other relevant stakeholders around this matter and expect a positive resolution shortly.
We apologise for any inconvenience this may cause and will provide updates as the situation progresses
Posted Sep 02, 2025 - 11:16 UTC

Identified

We have identified instability in Senegal Free, Senegal Orange services. We have escalated this to the MMO for resolution.
Posted Sep 01, 2025 - 15:49 UTC
This incident affects: Senegal MMO services (Yas :: Web Deposit, Yas :: Payout, Orange :: Web Deposit, Orange :: Payout).