Performance degradation affecting Lesotho MPesa services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 14, 2025 - 08:00 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 14, 2025 - 06:54 UTC

Update

Unfortunately we are still experiencing an outage in our Lesotho MPesa deposit and payout gateways. MPesa is still working on restoring their services but have not given us an ETA for a resolution. We'll provide an update as soon as possible. Thank you for your patience.
Posted Mar 14, 2025 - 06:16 UTC

Identified

We have identified instability in Lesotho MPesa services. We have escalated this to the MMO for resolution.
Posted Mar 13, 2025 - 19:41 UTC
This incident affected: Lesotho MMO services (M-Pesa :: Web Deposit, M-Pesa :: Payout).