Performance degradation affecting Tanzania Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 16:21 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 01, 2025 - 12:34 UTC

Identified

We have identified instability in Tanzania Airtel services. We have escalated this to the MMO for resolution.
Posted Apr 01, 2025 - 11:07 UTC
This incident affected: Tanzania MMO services (Airtel :: Web Deposit, Airtel :: Payout).