Performance degradation affecting Cameroon Orange services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 03:10 UTC

Investigating

We are experiencing degraded performance in the Cameroon Orange services. We are investigating the issue.
Posted Jun 10, 2025 - 00:10 UTC
This incident affected: Cameroon MMO services (Orange :: Web Deposit, Orange :: Payout).