Scheduled maintenance has been completed, and we are currently verifying full MMO service availability.
Transaction flows are active and processing normally. However, the MMO portal remains unavailable at this time, and reconciliation for pending transactions will be delayed until portal access is fully restored.
We will continue to monitor the situation and provide further updates as they become available.
Posted May 20, 2026 - 12:54 UTC
Update
The Zamtel Money platform migration and infrastructure upgrade are still ongoing and are taking longer than initially expected. Zamtel continues to work on restoring the affected services as quickly as possible.
We appreciate your continued patience and understanding while the maintenance activities are being completed.
Posted May 19, 2026 - 17:17 UTC
Update
The Zamtel Money system migration and platform upgrade is still ongoing and taking longer than initially anticipated. MMO continues to actively work on restoring the services as quickly as possible.
We sincerely appreciate your continued patience and understanding while this work is being completed.
Posted May 18, 2026 - 09:56 UTC
Update
Unfortunately, the Zamtel Money system migration and platform upgrade is taking longer than initially anticipated. Zamtel is continuing to work on restoring services and currently estimates that services will be fully restored after 04:00 UTC 17.05.2026.
We appreciate your patience and understanding while this work is being completed.
Posted May 16, 2026 - 20:19 UTC
Update
Unfortunately we are still experiencing an outage in our Zamtel Zambia deposit and payout gateways. Zamtel is still working on restoring their services but have not given us an ETA for a resolution. We'll provide an update as soon as possible. Thank you for your patience.
Posted May 16, 2026 - 11:48 UTC
Update
Ongoing MMO maintenance is taking longer to be completed than originally scheduled. We will keep you updated on the progress.
Posted May 16, 2026 - 06:46 UTC
In progress
Scheduled maintenance has started. We will provide updates as necessary.
Posted May 15, 2026 - 22:03 UTC
Scheduled
Scheduled maintenance has started. We will provide updates as necessary.