Performance degradation affecting Tanzania Airtel services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Jul 01, 2025 - 20:40 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2025 - 16:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 15:17 UTC

Update

This is a quick update to inform you that we are still experiencing an outage in our Airtel Tanzania deposit and payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jul 01, 2025 - 15:02 UTC

Identified

We have identified instability in Tanzania Airtel services. We have escalated this to the MMO for resolution.
Posted Jul 01, 2025 - 11:26 UTC
This incident affected: Tanzania MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).