Performance degradation affecting Rwanda MTN services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 20:40 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 28, 2024 - 19:49 UTC
Identified
We have identified instability in Rwanda MTN services. We have escalated this to the MMO for resolution.
Posted Nov 28, 2024 - 17:15 UTC
This incident affected: Rwanda MMO services (MTN :: Web Deposit, MTN :: Payout).