Performance degradation affecting Zambia Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted 16 days ago. Mar 17, 2025 - 21:48 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted 16 days ago. Mar 17, 2025 - 20:29 UTC

Update

Zambia Airtel is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted 16 days ago. Mar 17, 2025 - 13:45 UTC

Update

This is a quick update to inform you that we are still experiencing instability in Zambia Airtel services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted 18 days ago. Mar 16, 2025 - 11:06 UTC

Identified

We have identified instability in Zambia Airtel services. We have escalated this to the MNO for resolution.
Posted 18 days ago. Mar 16, 2025 - 00:31 UTC
This incident affected: Zambia MMO services (Airtel :: Web Deposit).