Airtel Malawi scheduled maintenance

Incident Report for PawaPay

Resolved

We are pleased to inform you that we are no longer experiencing any instability and services are fully operational again. Thank you for your patience.
Posted Apr 07, 2026 - 03:09 UTC

Monitoring

Airtel Malawi maintenance has been finished and we can see improvements in processing transactions. However, we will keep monitoring the situation and update you in the next 30 minutes.
Posted Apr 07, 2026 - 01:24 UTC

Investigating

Scheduled maintenance has started. We will provide updates as necessary.
Posted Apr 06, 2026 - 23:36 UTC
This incident affected: Malawi MMO services (Airtel :: Web Deposit, Airtel :: Payout).