Performance degradation affecting Zambia MTN services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 29, 2025 - 20:12 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 29, 2025 - 18:41 UTC

Identified

We have identified instability in Zambia MTN services. We have escalated this to the MNO for resolution.
Posted Mar 29, 2025 - 17:25 UTC
This incident affected: Zambia MMO services (MTN :: Payout).