Performance degradation affecting Ghana AirtelTigo services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 07:48 UTC

Monitoring

A fix has been deployed by Ghana AirtelTigo. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 22, 2025 - 05:34 UTC

Investigating

We are experiencing an outage of the Ghana AirtelTigo services. We are investigating the issue.
Posted Mar 22, 2025 - 03:52 UTC
This incident affected: Ghana MMO services (AirtelTigo :: Web Deposit, AirtelTigo :: Payout).