Performance degradation affecting Lesotho M-Pesa services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 25, 2025 - 21:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 16:26 UTC

Identified

We have identified instability in Lesotho M-Pesa services. We have escalated this to the MMO for resolution.
Posted Mar 25, 2025 - 12:40 UTC
This incident affected: Lesotho MMO services (M-Pesa :: Web Deposit, M-Pesa :: Payout).