Performance degradation affecting Tanzania Halotel services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 21:41 UTC

Monitoring

A fix has been deployed by Tanzania Halotel We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jan 30, 2026 - 20:08 UTC

Update

This is a quick update to inform you that we are experiencing service outage in our Halotel Tanzania Web deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 30, 2026 - 16:13 UTC

Update

This is a quick update to inform you that we are still experiencing degraded performance in our Halotel Tanzania USSD deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 30, 2026 - 13:43 UTC

Identified

We are experiencing performance degradation in the Tanzania Halotel services. We are investigating the issue
Posted Jan 30, 2026 - 06:48 UTC

Monitoring

We are experiencing performance degradation in the Tanzania Halotel services. We are investigating the issue
Posted Jan 30, 2026 - 04:24 UTC

Update

Halotel is still facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 30, 2026 - 02:17 UTC

Identified

Halotel is still facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 30, 2026 - 00:04 UTC

Update

We are experiencing an outage of the Tanzania Halotel services. We are investigating the issue.
Posted Jan 29, 2026 - 22:46 UTC

Investigating

We are experiencing performance degradation in the Tanzania Halotel services. We are investigating the issue.
Posted Jan 29, 2026 - 21:54 UTC
This incident affected: Tanzania MMO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).